Reverse and Add

The “reverse and add” method is simple: choose a number, reverse its digits and add it to the original.
If the sum is not a palindrome (which means, it is not the same number from left to right and right to
left), repeat this procedure.
For example:
195 Initial number
591
—–
786
687
—–
1473
3741
—–
5214
4125
—–
9339 Resulting palindrome
In this particular case the palindrome ‘9339’ appeared after the 4th addition. This method leads
to palindromes in a few step for almost all of the integers. But there are interesting exceptions. 196
is the first number for which no palindrome has been found. It is not proven though, that there is no
such a palindrome.
You must write a program that give the resulting palindrome and the number of iterations (additions) to compute the palindrome.
You might assume that all tests data on this problem:
• will have an answer ,
• will be computable with less than 1000 iterations (additions),
• will yield a palindrome that is not greater than 4,294,967,295.
Input
The first line will have a number N (0 < N ≤ 100) with the number of test cases, the next N lines will
have a number P to compute its palindrome.
Output
For each of the N tests you will have to write a line with the following data : minimumnumberofiterations(additions)togettothepalindrome
and theresultingpalindromeitself separated by one space.
Sample Input
3
195
265
750
Sample Output
4 9339
5 45254
3 6666
代码

#include<bits/stdc++.h>
using namespace std;
int arr[17];
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        long long int p;
        cin>>p;
        int cnnt=0;
        while(1)
        {
            cnnt++;
            long long int q=0;
            long long int p1=p;
            while(p1>0)
            {
                q=q*10+p1%10;
                p1/=10;
            }
            p=q+p;
            q=p;
            int cnt=0;
            while(q>0)
            {
                arr[cnt]=q%10;
                q/=10;
                cnt++;
            }
            bool flag=true;
            for(int i=0;i<cnt;i++)
            {
                if(arr[i]!=arr[cnt-i-1])
                {
                    flag=false;
                    break;
                }
            }
            if(flag)
            {
                cout<<cnnt<<" "<<p<<endl;
                break;
            }
            memset(arr,0,sizeof(arr));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/88693756
Add