poj -1703 Find them, Catch them 并查集

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题目链接:http://poj.org/problem?id=1703

题意:有两个帮派,A x y表示查询x,y是否是同一个帮派(有三种情况),D x y表示x,y不是同个帮派。类似食物链poj 1182那题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 1e5;
int father[maxn];
int rank[maxn]; 

int find(int x)
{
    if(x != father[x])
    {
        int f = father[x];
        father[x] = find(father[x]);
        rank[x] = (rank[x]+rank[f])&1;// 表示只有两类 
    }
    return father[x];
}

int main()
{
    ios::sync_with_stdio(false);
    int t;
    scanf("%d", &t);
    while(t --)
    {
        int n, m;
        scanf("%d%d%*c", &n, &m);
        for(int i = 1; i <= n; i++)
            father[i] = i, rank[i] = 0;
        while(m --)
        {
            int x, y;
            char op;
            scanf("%c%d%d%*c", &op, &x, &y);
            int fx = find(x);
            int fy = find(y);
            if(op == 'A')
            {
                if(fx != fy)
                {
                    printf("Not sure yet.\n");
                    continue;
                }
                if(rank[x] == rank[y])
                {
                    printf("In the same gang.\n");
                    continue;
                }
                else
                    printf("In different gangs.\n");    
            }
            else 
            {
                father[fx] = fy;
                rank[fx] = (rank[y]+1-rank[x]) & 1;
            }
        }
    } 
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_38295645/article/details/81429296
今日推荐