POJ 1703——Find them, Catch them【并查集变形】

题目传送门


Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.


Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”


Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4


Sample Output

Not sure yet.
In different gangs.
In the same gang.


题意

在这个城市里有两个黑帮团伙,现在给出n个人,每个人都属于这两个帮派中的一个,m次操作,操作分两种:

  • D x y:x于y不在一个团伙里
  • A x y:查询x与y的关系,即是否在同一团伙或者不确定

对于每次查询,如果两个人在一个团伙则输出”In the same gang.“,如果两个人不在一个团伙则输出”In different gangs.“,如果不确定则输出”Not sure yet.“


题解

  • 带权并查集,但是不够优美~~~
  • 定义 1~n 为A团伙,n+1 ~ n+n 为B团伙
  • 每次确定关系时:join(a, b+n),join(b, a+n)
  • 查询时:
    如果a,b根节点相同,则为同伙。
    如果a,b+n根节点相同,则为不同伙。
    否则为不确定

AC-Code

#include <bits/stdc++.h>
using namespace std;

const int MAXN = 1e5 + 7;

int pre[MAXN << 1];
int findx(int x) {
	return x == pre[x] ? x : pre[x] = findx(pre[x]);
}
void join(int x, int y) {
	int xx = findx(x);
	int yy = findx(y);
	if (xx != yy)
		pre[xx] = yy;
}
int main() {
	int T;
	scanf("%d", &T);
	while (T--) {
		int n, m;
		cin >> n >> m;
		for (int i = 1; i <= 2 * n; i++)
			pre[i] = i;
		while (m--) {
			char c;
			int a, b;
			getchar();
			scanf("%c%d%d", &c, &a, &b);
			//cout << "c:" << c << endl;
			if (c == 'D') {
				join(a, b + n);
				join(b, a + n);
			}
			else {
				int aa = findx(a);
				int bb = findx(b);
				if (aa == bb)
					cout << "In the same gang." << endl;
				else if (aa == findx(b + n))
					cout << "In different gangs." << endl;
				else
					cout << "Not sure yet." << endl;
			}
		}

	}

}
发布了104 篇原创文章 · 获赞 60 · 访问量 5868

猜你喜欢

转载自blog.csdn.net/Q_1849805767/article/details/103267444
今日推荐