HDU5666 Segment【大数】

Segment

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2604 Accepted Submission(s): 986

Problem Description
Silen August does not like to talk with others.She like to find some interesting problems.
Today she finds an interesting problem.She finds a segment x+y=q.The segment intersect the axis and produce a delta.She links some line between (0,0) and the node on the segment whose coordinate are integers.
Please calculate how many nodes are in the delta and not on the segments,output answer mod P.

Input
First line has a number,T,means testcase number.
Then,each line has two integers q, p.
q is a prime number,and 2≤q≤1018,1≤P≤1018,1≤T≤10.

Output
Output 1 number to each testcase,answer mod P.

Sample Input
1
2 107

Sample Output
0

Source
BestCoder Round #80

问题链接HDU5666 Segment
问题简述:(略)
问题分析
    大数问题,用Java来实现比较简单。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的Java语言程序如下:

/* HDU5666 Segment */

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);

		BigInteger one = BigInteger.valueOf(1);
		BigInteger two = BigInteger.valueOf(2);
		BigInteger a, b, ans;
		int t = cin.nextInt();
		while(t-- > 0) {
			a = cin.nextBigInteger();
			b = cin.nextBigInteger();
			ans = (a.subtract(one).multiply(a.subtract(two))).divide(two);

			System.out.println(ans.remainder(b));
		}
	}
}
发布了2126 篇原创文章 · 获赞 2306 · 访问量 254万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/104470210
今日推荐