2019新生集训第二场 7-1 到底有多二

一个整数“犯二的程度”定义为该数字中包含2的个数与其位数的比值。如果这个数是负数,则程度增加0.5倍;如果还是个偶数,则再增加1倍。例如数字-13142223336是个11位数,其中有3个2,并且是负数,也是偶数,则它的犯二程度计算为:3/11×1.5×2×100%,约为81.82%。本题就请你计算一个给定整数到底有多二。

输入格式:
输入第一行给出一个不超过50位的整数N。

输出格式:
在一行中输出N犯二的程度,保留小数点后两位。

输入样例:
-13142223336

输出样例:
81.82%

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s;
    cin>>s;
    int len = s.length();
    int p1 = 0,sum = 0;
    if(s[0]=='-')
    {
        len--;
        p1 = 1;//说明是负数
    }
    for(int i = 0;i<s.length();i++)
    {
        if(s[i]=='2')
            sum++;
    }
    double a = 1.0*sum/len;
    if(s[0]=='-')
        a = a*1.5;
    char c = s[s.length()-1];
    if((c-'0')%2==0)
        a = a*2;
    printf("%.2f%%",100*a);
}

发布了21 篇原创文章 · 获赞 5 · 访问量 501

猜你喜欢

转载自blog.csdn.net/qq_43748331/article/details/104273612