1031 Hello World for U (20分)【图形输出】

1031 Hello World for U (20分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

解题思路:

题目很好理解,要我们将给定的字符串按u形输出,要注意以下几个要求:

1.u形要尽可能的像正方形。

2.n1=n3==max<=n2,且n1+n2+n3-2=len,这两个式子很关键,首先利用后一个式子可以求出最大的n1,n3,然后再n2。

3.求出n1,n2,n3后打印即可。

#include<iostream>
#include<string>
using namespace std;

int main()
{
	string s;
	cin >> s;
	int len = s.length();
	int n = (len + 2) / 3;
	int t = len - 1, h = 0;
	int n2 = len + 2 - n - n;
	for (int i = 0; i < n - 1; i++)
	{
		for (int j = 1; j <= n2; j++) 
		{
			if (j == 1)
				cout << s[h];
			else if (j == n2)
				cout << s[t] << endl;
			else cout << " ";
		}
		h++;
		t--;
	}
	for (int i = h; i <= t; i++)
		cout << s[i];
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104628736