PAT甲级---1054 The Dominant Color

PAT甲级—1054 The Dominant Color

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2
24
). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:
For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24

#include<iostream>
using namespace std;
const int MAXN=16777216;

int main(){
    
    
	int m,n;
	while(scanf("%d%d",&m,&n)!=EOF){
    
    
		int a[n][m];
		for(int i=0;i<n;i++){
    
    
			for(int j=0;j<m;j++){
    
    
				scanf("%d",&a[i][j]);
			}
		}
	
		long long b[MAXN]={
    
    0};
		for(int i=0;i<n;i++){
    
    
			for(int j=0;j<m;j++){
    
    
				b[a[i][j]]++;
			}
		}
		int num=b[0];
		int k=0;
		for(int i=0;i<MAXN;i++){
    
    
			if(num<b[i]){
    
    
				num=b[i];
				k=i;	
			}		
		}
		printf("%d",k);	
	}
	
	return 0;
}

错误
参考答案

#include <iostream>
#include <map>
using namespace std;
int main() {
    
    
    int m, n;
    scanf("%d %d", &m, &n);
    map<int, int> arr;
    int half = m * n / 2;
    for(int i = 0; i < n; i++) {
    
    
        for(int j = 0; j < m; j++) {
    
    
            int temp;
            scanf("%d", &temp);
            arr[temp]++;
            if(arr[temp] > half) {
    
    
                printf("%d", temp);
                return 0;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44411458/article/details/123219956