PAT Advanced 1054 The Dominant Color (20分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 8), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤) and N (≤) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
 

Sample Output:

24

这道题主要考察找最大值,在那么多颜色中,找出最大值

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
int main() {
    int M, N, S, max_num = 0;
    cin >> M >> N;
    string tmp, res;
    unordered_map<string, int> m;
    S = M * N;
    while(S--) {
        cin >> tmp;
        m[tmp]++;
    }
    vector<pair<string,int>> v(m.begin(), m.end());
    for(int i = 0; i < v.size(); i++){
        if(v[i].second > max_num) {
            max_num = v[i].second;
            res = v[i].first;
        }
    }
    cout << res << endl;
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/littlepage/p/12241112.html