PAT--1054 The Dominant Color (20 分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24
#include <iostream>
#include <bits/stdc++.h>

using namespace std;

int main()
{
    map<int,int> a;

    int n,m;
    cin>>n>>m;
    int num = m*n;
    int half = num/2;

    int temp;
    for(int i=0; i<num; i++)
    {
        cin>>temp;
        a[temp]++;
        if(a[temp]>half){
            cout<<temp;
            break;
        }
    }




    //cout << "Hello world!" << endl;
    return 0;
}

 注:

本来浏览一遍题意,是想桶排序,结果看到了数据的范围太大,放弃。

就看到了map的便利,以后在编码过程要注意map的使用。map可以当做数组的用法

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/99104666