【PAT甲级】1054 The Dominant Color (20)

题目链接

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 2^24^). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

思路:

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <map>
#include <stack>
#include <cmath>
#include <vector>
#include <sstream>
#include <algorithm>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const int N = 1e5+5;

int main() {
    int n,m;
    scanf("%d%d",&n,&m);
    int cnt=0,tmp;
    rep(i,0,n) {
        rep(j,0,m) {
            int x;
            scanf("%d",&x);
            if(cnt==0) {
                tmp=x;
                cnt++;
            } else {
                if(tmp==x) {
                    cnt++;
                } else {
                    cnt--;
                }
            }
        }
    }
    printf("%d\n",tmp);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81349194