PAT 1054 The Dominant Color (20)

1054 The Dominant Color (20)(20 分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 2^24^). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

思路:

可以一边输入,一边用map统计 ,一旦统计到超过半数,即可结束。

代码:

扫描二维码关注公众号,回复: 2674420 查看本文章
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>  
#include <set>
using namespace std;

map<int, int> color;

int main()
{
	int m, n;
	scanf("%d%d", &m, &n);
	int half = m * n / 2;
	for (int i = 0; i < n; i++)
	{
		for (int j = 0; j < m; j++)
		{
			int c;
			scanf("%d", &c);
			color[c]++;
			if (half < color[c])
			{
				printf("%d\n", c);
				return 0;
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ryo_218/article/details/81489745