PAT A 1054 The Dominant Color

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 2^24^). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

就为了防止内存超限,用map

#include<cstdio>
#include<map>
using namespace std;

int main() {
    int m, n;
    scanf("%d %d", &m, &n);
    map<int, int>count;

    for (int i = 0; i < n; i++)
        for (int j = 0; j < m; j++) {
            int num;
            scanf("%d", &num);
            if (count.find(num) != count.end()) count[num]++;//注意这种写法
            else count[num] = 1;
        }
    int index = 0, max = 0;
    for (map<int, int>::iterator it = count.begin(); it != count.end(); it++) {
        if (it->second > max) {
            index = it->first;
            max = it->second;
        }
    }
    printf("%d\n", index);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Joah_Ge/article/details/81116367