1054 The Dominant Color (20 分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

代码:

#include "iostream"

#include "string"

#include "map"

using namespace std;

int main(){

    int m,n;

    map<string,int> mp;

    string current;

    scanf("%d %d",&m,&n);

    for (int i=0; i<n; i++) {

        for (int j=0; j<m; j++) {

            cin >> current;

            if (mp.find(current)!=mp.end()) {

                mp[current]++;

            }

            else{

                mp[current]=1;

            }

        }

    }

    string k;

    int max=0;

    map<string,int>::iterator it=mp.begin();

    while (it!=mp.end()) {

        if (it->second>max) {

            k=it->first;

            max=it->second;

        }

        it++;

    }

    cout << k;

反思;

此题很简单,除了map之外,还可以运用擂台pk方法去做,具体和一维数组找dominate number 一样,有异曲同工之处。

发布了14 篇原创文章 · 获赞 0 · 访问量 141

猜你喜欢

转载自blog.csdn.net/Yanhaoming1999/article/details/102755828