1054 The Dominant Color(20 分)(C++)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N(for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

方法一:贪心思想,满足要求的数是超过sum/2,如果我们对整个数列遍历,非这个数就count--;是的话就count++;有且仅有唯一的一个出现次数超过sum/2的数可以满足count最终结果大于0。我们在遍历过程中遇到count小于等于0就换数字。最后留下的一定是我们要找的数。

#include<iostream>
using namespace std;
int main(){
    int n,m,temp,x,count=0;
    scanf("%d %d",&n,&m);
    int sum=n*m;
    for(int i=0;i<sum;i++){
        scanf("%d",&x);
        if(i==0)
            temp=x;
        if(x==temp)
            count++;
        else if(count>0)
            count--;
        else{
            temp=x;
            count=1;
        }
    }
    printf("%d",temp);
}

如果上面的贪心不太理解的话,也可以直接暴力一点,一个个计数,map映射即可。

#include<iostream>
#include<map>
#include<cstdio>
using namespace std;
int main(){
    std::map<int, int> map;
    int n,m;
	  scanf("%d %d",&n,&m);
    int half=m*n/2;
    int sum=n*m;
    for(int i=0;i<sum;i++){
        int x;
        scanf("%d",&x);
        map[x]++;
        if(map[x]>half){
            printf("%d",x);
            return 0;
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82152175