1054 The Dominant Color (20 分)

1054 The Dominant Color (20 分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

代码:

#include<bits/stdc++.h>	
using namespace std;
int main()
{
	map<int, int>mp;
	int n , m ;
	scanf("%d %d",&n,&m);
	for(int i = 1; i <= m; i ++)
	{
		for(int j = 1; j <= n; j ++){
			int x;
			scanf("%d",&x);		
			mp[x]++;
		} 
	}	
	map<int,int>::iterator it = mp.begin();
	int maxn = -1,maxncnt = -1;
	while(it !=mp.end())
	{
		if(it->second > maxncnt){
			maxn = it->first;
			maxncnt = it->second;
		} 
		it++;
	}
	cout<<maxn<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/84502659