HDOJ1787 GCD Again-欧拉函数

题目大意:求1到n-1与n不互质数的个数

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1787

Problem Description

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!

Good Luck!



Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.
 

Sample Input
 
  
2 4 0
 

Sample Output
 
  
0 1
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1788  1695  1573  2824  1286 
 


这题是欧拉函数的模板题,答案是n-1-φ(n),φ(n)是欧拉函数即1到n中与n互质的数个数。

欧拉函数:点击打开链接

要注意下result/i*(i-1)那里,刚开始我写的result*(i-1)/i,WA了,后来看了别人的代码才知道这样写溢出了。

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int main(){
	int n;
	while(scanf("%d",&n) != EOF && n){
		int t = n;
		int result = n;				//计算欧拉函数	
		//找n的所有质因数
		for(int i = 2;i*i <= n;i++) {
			if(n % i == 0)	{			
				result = result / i * (i-1);			//找到质因数 		
			}
			while(n % i == 0)	
				n /= i;						
		}
		if(n != 1){
			result = result / n * (n-1);
		}
		printf("%d\n",t - 1 -result);				
	}		
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lmhlmh_/article/details/80431311
今日推荐