HDU 4283 You Are the One(区间dp)

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5303    Accepted Submission(s): 2559


Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 

Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 

Output
  For each test case, output the least summary of unhappiness .
 

Sample Input
 
  
2    5 1 2 3 4 5 5 5 4 3 2 2
 

Sample Output
 
  
Case #1: 20 Case #2: 24

#include<bits/stdc++.h>
using namespace std;
const int maxn=102;
int dp[maxn][maxn],sum[maxn],a[maxn];
int main()
{
    int T,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        int n;scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
        }
        for(int i=1;i<=n;i++)
            for(int j=i;j<=n;j++)
            dp[i][j]=1e8;
        for(int i=n;i>=1;i--)
        {
            for(int j=i;j<=n;j++)
            {
                for(int k=i;k<=j;k++)//在k位置加入i,k后的数字每一个都往后移(k-i+1)个位置
                {
                    dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]+a[i]*(k-i)+(sum[j]-sum[k])*(k-i+1));
                }
            }
        }
        printf("Case #%d: %d\n",++cas,dp[1][n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albertluf/article/details/80615888