[区间DP] G - You Are the One HDU - 4283

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5707    Accepted Submission(s): 2771


 

Problem Description

  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

 

Input

  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)

 

Output

  For each test case, output the least summary of unhappiness .

 

Sample Input

 

2   

5

1 2 3 4 5

5

5 4 3 2 2

 

Sample Output

 

Case #1: 20

Case #2: 24

 

Source

2012 ACM/ICPC Asia Regional Tianjin Online

#include <bits/stdc++.h>
using namespace std;
const int mn = 110;
const int inf = 0x3f3f3f3f;

int d[mn], sum[mn];
int dp[mn][mn];
int main()
{	
	int T; scanf("%d", &T);
	for (int cas = 1; cas <= T; cas++)
	{
		sum[0] = 0;
		memset(dp, 0, sizeof dp);
		
		int n; scanf("%d", &n);
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &d[i]);
			//dp[i][i] = d[i];
			sum[i] = sum[i - 1] + d[i];
		}
		
		for (int l = 2; l <= n; l++)
		{
			for (int i = 1; i <= n && i + l - 1 <= n; i++)
			{
				int j = i + l - 1;
				dp[i][j] = inf;
				for (int k = i; k <= j; k++)
				{
					int t = dp[i + 1][k] + (k - i) * d[i] + dp[k + 1][j] + (k - i + 1) * (sum[j] - sum[k]);
					dp[i][j] = min(t, dp[i][j]);
				}
			}
		}
		
		printf("Case #%d: %d\n", cas, dp[1][n]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/84503180