【区间DP】HDU - 4283 C - You Are the One

HDU - 4283  C - You Are the One 

  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him? 

Input

  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100) 
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100) 

Output

  For each test case, output the least summary of unhappiness . 

Sample Input

2
  
5
1
2
3
4
5

5
5
4
3
2
2

Sample Output

Case #1: 20
Case #2: 24

给你1-n个小男孩,他们按顺序上台表演,每个人都有一个屌丝值

每个人上台后得到的不开心值=(k-1)*val,  k是该男孩为第k个上台的

有一个小黑屋(相当于栈)可以吧小男孩拉进来,让他之后演出,先进后出

最开始以为是贪心wa了,后来发现是个栈

因为栈里面不管有多少数,如果i是第k个跑出来的,那么在他之前放进来,其余的人是排在第k+1个之后出场的,也就是一个子问题dp[i+k][j],对于这个区间的人,由于排在第k+1个之后,所以整体愤怒值要加上k*(sigma(i+k--j))

#include <bits/stdc++.h>
using namespace std;
const int inf=0x3f3f3f3f;
int value[105],sum[105],dp[105][105];
int main()
{
    int T,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&value[i]);
            sum[i]=sum[i-1]+value[i];
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                dp[i][j]=inf;
            }
        }
        for(int len=1;len<=n;len++)
        {
            for(int i=1;i<=n;i++)
            {
                int j=i+len;
                if(j>n) break;
                for(int k=i;k<=j;k++)
                {
                    dp[i][j]=min(dp[i][j],value[i]*(k-i)+(k-i+1)*(sum[j]-sum[k])+dp[i+1][k]+dp[k+1][j]);
                }
            }
        }
        printf("Case #%d: %d\n",++cas,dp[1][n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/82780546