poj 1523 SPF(模板题)(Tarjan 关节点的朴素算法)

SPF
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7226   Accepted: 3298

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 
Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 
The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets
思路:

这是一个求无向图的关节点模板题,需要学会Tarjan算法。

代码:

//4160K	16MS
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define min(a,b) ((a)>(b)?(b):(a))
int edge[1001][1001];
int vis[1001];//访问状态
int nodes;//顶点数目
int tmpdfn;//dfs时记录当前的深度优先搜索序号
int dfn[1001];
int low[1001];
int son;//根节点的子女结点的个数
int subnets[1001];//去除该点后的连通分量

void dfs(int u)
{
    for(int v=1;v<=nodes;v++)
    {
        if(edge[u][v])
        {
            if(!vis[v])
            {
                vis[v]=1;
                tmpdfn++;dfn[v]=low[v]=tmpdfn;
                dfs(v);
                low[u]=min(low[u],low[v]);
                if(low[v]>=dfn[u])
                {
                    if(u!=1)subnets[u]++;
                    if(u==1)son++;
                }
            }
            else
                low[u]=min(low[u],dfn[v]);
        }
    }
}

void init()
{
    low[1]=dfn[1]=1;
    tmpdfn=1;son=0;
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    memset(subnets,0,sizeof(subnets));
}

int main()
{
    int u,v;
    int find;//是否寻找到关节点
    int number=1;//
    while(1)
    {
        scanf("%d",&u);
        if(u==0) break;
        memset(edge,0,sizeof(edge));
        nodes=0;
        scanf("%d",&v);
        if(v>nodes) nodes=v;
        if(u>nodes) nodes=u;
        edge[u][v]=edge[v][u]=1;
        while(1)
        {
            scanf("%d",&u);
            if(u==0) break;
            scanf("%d",&v);
            if(v>nodes) nodes=v;
            if(u>nodes) nodes=u;
            edge[u][v]=edge[v][u]=1;
        }
        if(number>1)cout<<endl;
        printf("Network #%d\n",number);
        number++;
        init();
        dfs(1);
        if(son>1)subnets[1]=son-1;
        find=0;
        for(int i=1;i<=nodes;i++)
        {
            if(subnets[i])
            {
                find=1;
                printf("  SPF node %d leaves %d subnets\n",i,subnets[i]+1);
            }
        }
        if(!find)
            printf("  No SPF nodes\n");
    }
    return 0;
}



扫描二维码关注公众号,回复: 1836521 查看本文章


猜你喜欢

转载自blog.csdn.net/kaisa158/article/details/49103255
今日推荐