POJ 1523 Tarjan

SPF
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10107   Accepted: 4531

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source

Greater New York 2000

主要是要知道割点性质 如果low[v]>=dfn[u] 且不是根节点 那么输出孩子个数+1 如果是根节点 输出孩子个数就行了

具体见代码吧

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 10000;
const int MAX_M  = 100000;
struct edge{
int v,next;
}e[MAX_M];
int dfn[MAX_N],low[MAX_N];
int idx = 0;
int scc = 0;
int son = 0;
int in_stack[MAX_M];
int p[MAX_M],eid,ans[MAX_M];
void init(){
   memset(p,-1,sizeof(p));
   eid = 0;
}
void Insert(int u,int v){
    e[eid].v = v;
    e[eid].next = p[u];
    p[u] = eid++;
}
int nodes_min,nodes_max;
void tarjan(int u){
    dfn[u] = low[u] = ++idx;
    in_stack[u] = 1;
    for(int i = p[u];i!=-1;i=e[i].next){
        int v = e[i].v;
        if(!dfn[v]){
            tarjan(v);
            low[u] = min(low[u],low[v]);
          if(low[v]>=dfn[u])
          {
              if(u==1) son++;
              else ans[u]++;
          }
        }
        else if(in_stack[v]){
            low[u] = min(low[u],dfn[v]);
        }
    }
}

int main(){
    init();
    int Case=1,u,v,
    nodes_max=0;
    while(1){
      scanf("%d",&u);
      if(u==0) {
            break;
      }
      nodes_max=max(nodes_max,u);
      scanf("%d",&v);
      nodes_max=max(nodes_max,v);
      Insert(u,v);
      Insert(v,u);
      while(1){
            scanf("%d",&u);
            if(u==0) break;
            nodes_max=max(nodes_max,u);
            scanf("%d",&v);
            nodes_max=max(nodes_max,v);
            Insert(u,v);
            Insert(v,u);
      }
      /*for(int i=nodes_min;i<=nodes_max;i++){
        if(!dfn[i]) tarjan(i);
      }*/
      tarjan(1);
      if(son>1) ans[1] = son-1;
      int have = 0;
      Case>1?printf("\nNetwork #%d\n",Case++):printf("Network #%d\n",Case++);
      for(int i=1;i<=nodes_max;++i){
        if(ans[i]){
            have = 1;
            printf("  SPF node %d leaves %d subnets\n",i,ans[i]+1);
        }
      }
      if(!have) printf("  No SPF nodes\n");
      init();
      memset(e,0,sizeof(e));
      memset(ans,0,sizeof(ans));
      memset(in_stack,0,sizeof(in_stack));
      memset(dfn,0,sizeof(dfn));
      memset(low,0,sizeof(low));
      scc = 0;
      son = 0;
      idx = 0;
      nodes_max= 0;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/81013578