poj 1523 SPF【割点】

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0
Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

题意:求删去一个割点能分成几个块(割点就是一个连通图删除这个点后不再连通)

怎么求割点在我这篇博客里提了,还有模板,这道题需要一点点改动模板

AC代码:

#include<cstring>
#include<string>
#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<map>
#include<vector>
#include<stack>
#define inf 0x3f3f3f3f
#include<queue>
#include<set>
using namespace std;
typedef long long ll;
const int N=2e3+10;
const int M=2e6+10;

struct node
{
    int v,ne;
}edge[M];
int head[N],low[N],dfn[N];
int iscut[N];//记录割去这个点后分成的块数
int top,cut,e,n,son;

void init()
{
    memset(head,-1,sizeof(head));
    e=0;
}

void add(int a,int b)
{
    edge[e].v=b;
    edge[e].ne=head[a];
    head[a]=e++;
}

void tarjan(int now,int pre)
{
    low[now]=dfn[now]=++top;
    for(int i=head[now];i!=-1;i=edge[i].ne)
    {
        int v=edge[i].v;
        if(!dfn[v])
        {
            tarjan(v,now);
            low[now]=min(low[now],low[v]);
            if(low[v]>=dfn[now])
            {
                if(now==1)
                    son++;
                else
                    iscut[now]++;
            }  //每次++是因为:可能有很多的块通过这个点连成强连通,所以每次要++
        }
        else
            low[now]=min(low[now],dfn[v]);
    }
}

void solve()
{
    memset(low,0,sizeof(low));
    memset(dfn,0,sizeof(dfn));
    memset(iscut,0,sizeof(iscut));
    top=0;
    son=0;
    tarjan(1,0);
}

int main()
{
    int a,b,cas=0;
    while(scanf("%d",&a),a)
    {
        init();
        n=0;
        scanf("%d",&b);
        n=max(a,b);
        add(a,b);
        add(b,a);
        while(scanf("%d",&a),a)
        {
            scanf("%d",&b);
            add(a,b);
            add(b,a);
            n=max(n,max(a,b));
        }
        solve();
        if(son>1)//对于根节点,只需要判断他的儿子有几个就行
            iscut[1]=son-1;
        if(cas>0) printf("\n");//注意格式!!!
        printf("Network #%d\n",++cas);
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            if(iscut[i])
            {
                flag=1;
                printf("  SPF node %d leaves %d subnets\n",i,iscut[i]+1);
            }
        }
        if(!flag)
            printf("  No SPF nodes\n");
    }
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/qq_41984014/article/details/84144340