POJ 1523 SPF (割点+连通块)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/84071842

SPF

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

题目大意:给一个无向图,输出割点和删除这个割点后的连通块数量  和POJ2117差不多

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
const int N=10000+20;
const int M=200000+20;
int first[N],dfn[N],low[N],son[N];
bool cut[N];
int tot,time,root;
struct node
{
    int v,next;
}e[M];
void init()
{
    mem(first,-1);
    mem(dfn,0);
    mem(low,0);
    mem(son,0);
    mem(cut,0);
    tot=time=0;
}
void adde(int u,int v)
{
    e[tot].v=v;
    e[tot].next=first[u];
    first[u]=tot++;
}
void tarjan(int u,int pre)
{
    dfn[u]=low[u]=++time;
    int pos=0;
    for(int i=first[u];~i;i=e[i].next)
    {
        int v=e[i].v;
        if(v==pre) continue;
        if(!dfn[v])
        {
            pos++;
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(u==root&&pos>1)cut[u]=1;
            else if(u!=root&&low[v]>=dfn[u]){cut[u]=1;son[u]++;}
        }
        else low[u]=min(low[u],dfn[v]);
    }
    if(u==root) son[u]=pos-1;
}
void solve(int n)
{
    int ans=0;
    root=1;
    tarjan(1,-1);
    for(int i=1;i<=n;i++)
        if(cut[i])
    {
        ans++;
        printf("  SPF node %d leaves %d subnets\n",i,son[i]+1);
    }
    if(ans==0)
        printf("  No SPF nodes\n");
}
int main()
{
    int u,v,n,k=1;
    while(~scanf("%d",&u)&&u)
    {
        n=1;
        init();
        n=max(n,u);
        scanf("%d",&v);
        n=max(n,v);
        adde(u,v);
        adde(v,u);
        while(~scanf("%d",&u)&&u)
        {
            n=max(n,u);
            scanf("%d",&v);
            n=max(n,v);
            adde(u,v);
            adde(v,u);
        }
        if(k>1) printf("\n");
        printf("Network #%d\n",k++);
        solve(n);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/84071842