WOJ1416-WOJ

Alex likes solving problems on WOJ (http://acm.whu.edu.cn/oak). As we all know, a beautiful balloon will appears when a
problem is solved. Alex loves balloons, especially when they're in a consecutive column, from which he can get a sense of
accomplishment.

Problems on WOJ have a variety of difficulties. Hard problems cost more time, while easy ones may be "killed in 1
second". Now we know that WOJ has N problems, numbered from 1 to N. Alex calls the solved problems in one
consecutive column as a "successful string". The length of a successful string is the number of problems it contains. Also
he defines the value of a successful string as the square of the string's length. Alex hopes to solve a certain number of
problems in M time, so he can get some successful strings, now he wants to maximize the sum of all the strings' value.


输入格式

The input consists of multiple test cases. The first line of input contains an integer T, which is the number of test cases.

The input consists of several test cases. Each test case starts with a line containing two integers N and M.
Each of the following N lines contains a single integer Mi indicating the time cost on solving the i-th problem.
(1<=N, M<=100)

[Technical Specification] T is an integer, and T <= 15;
N and M are integers, 1 <= N, M <= 100.
Mi are integers and, 0 <= Mi <= 100

输出格式

For each test case, print a single line containing a number indicating the maximum sum.

样例输入

1
10 9
6
1
3
1
5
3
2
5
5
5

样例输出

10


#include<stdio.h>
#include<string.h>
int n,que[101],visited[102][102][102];
int dfs(int no,int rest,int cons) {
	int k1,k2,max;
	k1=k2=max=0;
	if(visited[no][rest][cons]) return visited[no][rest][cons];
	if(no==n+1) return 0;
	if(rest>=que[no])
		k1=dfs(no+1,rest-que[no],cons+1);
	k2=dfs(no+1,rest,0);
	if(k1>=k2) max=k1;
	else max=k2;
	if(!cons) {
		visited[no][rest][cons]=max;
	} else
		visited[no][rest][cons]=cons*2-1+max;
	return visited[no][rest][cons];
}
int main() {
	int t,i,time;
	scanf("%d",&t);
	while(t--) {
		memset(visited,0,sizeof(visited));
		scanf("%d %d",&n,&time);
		for(i=0; i<n; i++)
			scanf("%d",&que[i]);
		printf("%d\n",dfs(0,time,0));
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/lxq1071717521/article/details/77929684
今日推荐