1053 Path of Equal Weight (30)(30 分)---一般的树

Given a non-empty tree with root R, and with weight W~i~ assigned to each tree node T~i~. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

\ Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 2^30^, the given weight number. The next line contains N positive numbers where W~i~ (&lt1000) corresponds to the tree node T~i~. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A~1~, A~2~, ..., A~n~} is said to be greater than sequence {B~1~, B~2~, ..., B~m~} if there exists 1 <= k < min{n, m} such that A~i~ = B~i~ for i=1, ... k, and A~k+1~ > B~k+1~.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

这道题有个坑的地方,它要求当有多个路径能满足条件的时候,按照结点从小到大的顺序输出。既然这样,我们就可以用sort对每个节点的重量排个序。

结构体里有两个内容,child:存放孩子节点的下标,w:存放当前结点的重量

注意:由于题中的各个结点的数目不确定,贸然开数组很冒险,保险起见用vector来表示孩子结点。

代码如下:(注意sort排序) (sort排序的使用还是很奇妙的)

#include <iostream>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
struct Node
{
    vector<int> child;
    int w;
} node[200];
bool cmp(int a,int b)
{
    return node[a].w > node[b].w;
}
bool vis[200];
int weigh[200];
void  bfs(int root)
{
    queue<int> q;
    q.push(root);
    while(!q.empty())
    {
        int now = q.front();
        q.pop();
        node[now].w = weigh[now];
        int len = node[now].child.size();
        if(len!=0)
        {
            for(int i=0; i<len; i++)
            {
                q.push(node[now].child[i]);
            }
        }

    }
}
void dfs(int root,int ans,int k,int n)
{

    if(ans== k)
    {
        if(node[root].child.size() !=0)
            return ;
        cout<<weigh[0];
        for(int i=0; i<n; i++)
        {
            if(vis[i] == true)
            {
                cout<<" "<<node[i].w;
            }
        }
        cout<<endl;
        return ;
    }
    if(node[root].child.size()==0)
        return ;
    int len = node[root].child.size();
    for(int i=0; i<len; i++)
    {
        if(!vis[node[root].child[i]] && ans+node[node[root].child[i]].w <= k)
        {
            vis[node[root].child[i]] = true;
            dfs(node[root].child[i],ans+node[node[root].child[i]].w,k,n);
            vis[node[root].child[i]] = false;
        }
    }
}
int main()
{
    for(int i=0; i<200; i++)
        vis[i] = false;
    int n,m,k;
    cin>>n>>m>>k;
    for(int i=0; i<n; i++)
        cin>>weigh[i];
    int indx,Size;
    int indxw ;
    for(int i=0; i<m; i++)
    {
        cin>>indx>>Size;
        for(int j=0; j<Size; j++)
        {
            int x;
            cin>>x;
            node[indx].child.push_back(x);
            node[node[indx].child[j]].w = weigh[node[indx].child[j]];
        }
        sort(node[indx].child.begin(),node[indx].child.end(),cmp);
    }

    bfs(0);
    for(int i=0; i<200; i++)
        vis[i] = false;
    dfs(0,weigh[0],k,n);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38851184/article/details/81266243
今日推荐