dfs_1053 Path of Equal Weight (30 分)

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目中给出每个节点的权重,以及和每个节点相连的儿子节点,要求求出到达叶子节点上路径权值为s的所有路径,将路径上从根节点到儿子节点经历的权值按照由大到小的顺序输出,权值的比较为:如果位置上数值相同比较下一位,不相同那么较大的那个比小的大

根节点固定都为00

我们由根节点向下遍历,遍历顺序为由大根据儿子节点的权值大小向下比较,首先选择儿子节点权值大的,后面选择权值小的

知道叶子节点,如果到达叶子节点权值刚好为s,则输出这条路径上的权值,如果在路径中出现超过s的情况,删除这种情况,或者没有到达叶子节点就已经等于s,也删除

路径的存储使用per数组

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <cmath>
#define ll long long
#define INF 0x3f3f3f3f

using namespace std;
const int maxn = 105;
int n,m,s,w[maxn],per[maxn],kid[maxn];
vector<int> ch[maxn];

bool cmp(int a,int b)
{
    return w[a] < w[b];
}
void dfs(int p,int ww)
{
    if(ww > s) return ;
    if(ww == s && ch[p].size() == 0)
    {
        int path[maxn],index = 0;
        while(p != per[p])
        {
            path[index++] = p;
            p = per[p];
        }
        path[index++] = p;
        sort(path,path+index);
        for(int i = 0;i < index;i ++)
            printf("%d%c",w[path[i]],i==index-1?'\n':' ');
        return ;
    }
    for(int i = ch[p].size()-1;i >= 0;i --)
    {
        int x = ch[p][i];
        per[x] = p;
        dfs(x,ww+w[x]);
        per[x] = x;
    }
}
int main()
{
    scanf("%d%d%d",&n,&m,&s);
    for(int i =0 ;i < n;i ++)
        scanf("%d",w+i);
    for(int i =0 ;i < n;i ++) per[i] = i;
    int x,y,z;
    for(int i =0 ;i < m;i ++)
    {
        scanf("%d%d",&x,&y);
        for(int j = 0;j < y;j ++)
            scanf("%d",kid+j);
        sort(kid,kid+y,cmp);
        for(int j =0;j < y;j ++)
            ch[x].push_back(kid[j]);
    }
    dfs(0,w[0]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/84947610
今日推荐