PAT(树)——1053 Path of Equal Weight (30 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/86562986

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​ . The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​ , the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​ . Then M lines follow, each in the format:ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目大意:

给出一棵二叉树及其每个节点的权值,输出根节点到叶子节点总权值为s的路径,注意,各路径之间按照根节点往下从大到小排序。

题目解析:

建立结构体node,包含该节点的权值,包含所有子节点的动态数组,以及此节点的父节点序号(为了之后能递归遍历),每次分配子节点的时候让子节点按照从大到小排序。然后用dfs向后遍历,记录沿途权值的和,当遍历到子节点时比较和是否与s相等,如果是就用递归的方法反向输出。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct node{
	int value;
	vector<int> child;
	int parent;
}T[110];
bool cmp(int a,int b){
	return T[a].value>T[b].value;
}
void print(int v){
	if(v==0){
		printf("%d",T[v].value);
		return;
	}
	print(T[v].parent);
	printf(" %d",T[v].value);
}
void dfs(int v,int sum,int value){
	if(T[v].child.size()==0&&sum+T[v].value==value){
		print(v);
		printf("\n");
	}
	for(int i=0;i<T[v].child.size();i++){
		dfs(T[v].child[i],sum+T[v].value,value);
	}
}
int main()
{
    int n,m,value;
    scanf("%d%d%d",&n,&m,&value);
    for(int i=0;i<n;i++)
    	scanf("%d",&T[i].value);
    T[0].parent=0;
    for(int i=0;i<m;i++){
    	int parent,num;
    	scanf("%d%d",&parent,&num);
    	for(int j=0;j<num;j++){
    		int child;
    		scanf("%d",&child);
    		T[parent].child.push_back(child);
    		T[child].parent=parent;
    		sort(T[parent].child.begin(),T[parent].child.end(),cmp);
		}
	}
	dfs(0,0,value);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29978597/article/details/86562986