PAT 1053 Path of Equal Weight(树的遍历)

 Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

 Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

 Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

 where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

 For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

 Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

 题意: 给你一棵树,树上的每个结点有特定的权值,要求找到这么一条路径,起点是根节点,终点是叶子结点,路径上各结点的权值之和等于S

 思路:输出要求类似于字符串的字典序,那么可以将每个结点的子节点按权值从大到小排序,这样在遍历时输出自然符合要求

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long LL;
const int Max=105;
int Wei[Max],Mark[Max],Num;
int N,M,S;
vector<int> node[Max];
vector<int> Temp;
bool Compare(int x,int y)
{
    return Wei[x]>Wei[y];
}
void DFS(int cur,LL v)
{
    if(v>S)
        return ;

    if(v==S)
    {
        if(!node[cur].size())
        {
           int Len=Temp.size();
           for(int i=0;i<Len;i++)
           {
               if(i==0)
                    printf("%d",Temp[i]);
               else
                    printf(" %d",Temp[i]);
           }
           printf("\n");
        }
        return ;
    }

    int Len=node[cur].size();
    for(int i=0;i<Len;i++)
    {
        int x=node[cur][i];
        if(!Mark[x])
        {
            Mark[x]=1;
            Temp.push_back(Wei[x]);
            DFS(x,v+Wei[x]);
            Mark[x]=0;
            Temp.pop_back();
        }
    }
    return ;
}
int main()
{
    scanf("%d %d %d",&N,&M,&S);
    memset(Mark,0,sizeof(Mark));
    for(int i=0;i<N;i++)
    {
        scanf("%d",&Wei[i]);
    }

    int x,y,z;
    while(M--)
    {
        scanf("%d %d",&x,&y);
        for(int i=0;i<y;i++)
        {
            scanf("%d",&z);
            node[x].push_back(z);
        }
        sort(node[x].begin(),node[x].end(),Compare);
    }

    Num=0;
    Temp.push_back(Wei[0]);
    Mark[0]=1;
    DFS(0,Wei[0]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/84961300