PAT 1053 Path of Equal Weight[比较]

1053 Path of Equal Weight(30 分)

Given a non-empty tree with root R, and with weight Wi​​ assigned to each tree node Ti​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230​​, the given weight number. The next line contains N positive numbers where Wi​​ (<1000) corresponds to the tree node Ti​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1​​,A2​​,,An​​} is said to be greater than sequence {B1​​,B2​​,,Bm​​} if there exists 1k<min{n,m} such that Ai​​=Bi​​ for i=1,,k, and Ak+1​​>Bk+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目大意:给出一棵树,每个节点有一个编号和一个权重,输入给定了一个总权重K,求根节点R到任一叶子节点的路径代价=总权重K,找出所有这样的路径,并按字典序从大到小输出。

//我的代码:写不下去的:

#include <cstdio>
#include<iostream>
#include <vector>
#include<set>
#include<map>
using namespace std;
vector<int> vt[105];
map<int,int> mp;
vector<int> path;//用什么去存这个路径呢?
set<vector<int>> st;
void dfs(int r){//你这sum都没有作为参数传进去欸。。。
    if(vt[r].size()==0){//这里你还判断错了。。
        for(int i=0;i<path.size();i++){
            st.insert(path);
        }
        return ;
    }
    path.push_back(r);
    //最后怎么将其按照字典序排序呢?
    for(int i=vt[r][0];i<vt[r].size();i++){
        path.push_back(vt[r][i]);
        dfs(i);//.没有这个函数啊.
        path.erase(vt[r][i]);
    }

}
int main(){
    int n,leaf,k;
    cin>>n>>leaf>>k;
    int weight;
    for(int i=0;i<n;i++){
        cin>>weight;
        mp[i]=weight;
    }
    int nei=n-leaf;
    int u,ct,temp;
    for(int i=0;i<nei;i++){
        cin>>u>>ct;
        for(int j=0;j<ct;j++){
            cin>>temp;
            vt[u].push_back(temp);
        }
    }
    //path.push_back(0);
    dfs(0);
    return 0;
}
View Code

//dfs很多东西都没考虑好。

代码来自:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int target;
struct NODE {
    int w;
    vector<int> child;//将孩子节点作为一个向量进行存储。便于排序
};
vector<NODE> v;
vector<int> path;
void dfs(int index, int nodeNum, int sum) {
    if(sum > target) return ;
    if(sum == target) {
        if(v[index].child.size() != 0) return;//如果不是叶节点那么也返回。
        for(int i = 0; i < nodeNum; i++)
            printf("%d%c", v[path[i]].w, i != nodeNum - 1 ? ' ' : '\n');//直接在输出判断,十分简洁。
        return ;
    }
    for(int i = 0; i < v[index].child.size(); i++) {
        int node = v[index].child[i];
        path[nodeNum] = node;//不是push_back,向量没有erase函数,所以传了个参数表示节点数量。
        dfs(node, nodeNum + 1, sum + v[node].w);
    }

}
int cmp1(int a, int b) {
    return v[a].w > v[b].w;
}
int main() {
    int n, m, node, k;
    scanf("%d %d %d", &n, &m, &target);
    v.resize(n), path.resize(n);
    for(int i = 0; i < n; i++)
        scanf("%d", &v[i].w);
    for(int i = 0; i < m; i++) {
        scanf("%d %d", &node, &k);
        v[node].child.resize(k);
        for(int j = 0; j < k; j++)
            scanf("%d", &v[node].child[j]);
        sort(v[node].child.begin(), v[node].child.end(), cmp1);
        //对子节点从大到小排序,这样就能保证是按字典序最大来找到并输出的。
    }
    dfs(0, 1, v[0].w);
    return 0;
}

1.如何保证输出的路径是按字典序从大到小呢?将每个节点的子节点按权重从大到小排列即可。学习了

2.path如果用Vector表示,但是又不能弹出,该怎么办呢?在dfs中传入参数nodeNum,而不是在跳出递归进行计算时,使用path.size();下一次的就被覆盖了。

3.要注意dfs传入的参数,当前下标、解中节点数、总和。

//值得学习! 

猜你喜欢

转载自www.cnblogs.com/BlueBlueSea/p/9560510.html