PAT 甲级 1053 Path of Equal Weight

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​ . The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

在这里插入图片描述

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30, the given weight number. The next line contains N positive numbers where W​i​​(<1000) corresponds to the tree node T​i. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​ ,A​2​​ ,⋯,A​n​​ } is said to be greater than sequence {B​1​​ ,B​2​​ ,⋯,B​m​​ } if there exists 1≤k<min{n,m} such that A​i​​ =B​i​​ for i=1,⋯,k,and A​k+1​​ >B​k+1​​ .

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

解题思路:本题主要通过DFS对二叉树进行搜索,注意必须到根节点并且权值和满足题意才能输出其他都要返回,其次是sort函数的编写是按照孩子节点的权重从大到小排列。

代码:

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
	int data;
	vector<int> child;
}Node[100];
vector<int> line;  //存符合要求节点的权重 
int N,M,S;
int sum;
bool cmp(int a,int b){
	return  Node[a].data > Node[b].data;
}
void DFS(int root){
	if(Node[root].child.size() == 0&&sum == S){  //为叶子节点并且权重和为S 
		printf("%d",line[0]);
		for(int i = 1; i < line.size();i++)
			printf(" %d",line[i]);
		printf("\n");
		return;
	}
	else if(Node[root].child.size() == 0)
		return;
	else if(sum > S)
		return;
	for(int i = 0;i < Node[root].child.size();i++) //遍历每个孩子 
	{
		int child = Node[root].child[i];
		sum+=Node[child].data;				//将孩子节点信息加入 
		line.push_back(Node[child].data);
		DFS(child);
		line.pop_back();					//完成后需要将孩子节点信息删去 
		sum -= Node[child].data;
	}
}

int main(void){
	scanf("%d %d %d",&N,&M,&S)	;
	for(int i = 0;i < N;i++){
		scanf("%d",&Node[i].data);
	}
	for(int i = 0; i < M;i++){
		int pos,childnum,tempch;
		scanf("%d %d",&pos,&childnum);
		for(int j = 0;j < childnum;j++){
			scanf("%d",&tempch);
			Node[pos].child.push_back(tempch);
		}
		sort(Node[pos].child.begin(),Node[pos].child.end(),cmp);  //对孩子节点按权重从大到小排列 
	}
	sum = Node[0].data;  //将根节点权重加入sum 
	line.push_back(sum);
	DFS(0);  //根节点开始 
	return 0;
}
发布了24 篇原创文章 · 获赞 1 · 访问量 495

猜你喜欢

转载自blog.csdn.net/lovingcgq/article/details/104491837