【PAT甲级】1053 Path of Equal Weight(30 分)(树的遍历)

版权声明:本文为博主原创文章,转载请注明出处。 https://blog.csdn.net/feng_zhiyu/article/details/82498889

题目链接

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题意:给出树的结构和权值,找从根结点到叶子结点的路径上的权值相加之和等于给定目标数的路径,并且从大到小输出路径

思路:要求输出从大到小输出路径,将每个节点的孩子节点按权值由大到小排序可以保证这一点。然后递归遍历树,遍历过程中id表示节点的下标,sum表示当前的权值和。根据id确定for循环的父节点,sum表示当前路径的权值和。

代码:

#include <bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define drep(i,n,a) for(int i=n;i>=a;i--)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e5+5;

struct Node {
    int w;
    vector<int>child;
};
vector<int>P;
vector<Node>t;
bool cmp(int a,int b) {
    return t[a].w>t[b].w;
}
int n,m,w;

void dfs(int id,int sum) {
    if(sum>w) return ;
    if(sum==w) {
        if(t[id].child.size()) return ;
        for(int i=0; i<P.size(); i++) {
            printf("%d%c",t[P[i]].w,i==P.size()-1?'\n':' ');
        }
        return ;
    }
    for(auto child: t[id].child) {
        P.push_back(child);
        dfs(child,sum+t[child].w);
        P.pop_back();
    }
}
int main() {
    scanf("%d%d%d",&n,&m,&w);
    t.resize(n);
    for(int i=0; i<n; i++) {
        scanf("%d",&t[i].w);
    }
    for(int i=0; i<m; i++) {
        int node,k,x;
        scanf("%d%d",&node,&k);
        while(k--) {
            scanf("%d",&x);
            t[node].child.push_back(x);
        }
        sort(t[node].child.begin(),t[node].child.end(),cmp);
    }
    int root=0;
    P.push_back(root);
    dfs(root,t[0].w);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/82498889