PAT甲级 1053. Path of Equal Weight DFS,树的遍历记录路径

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目大意:给出树的结构和权值,找从根结点到叶子结点的路径上的权值相加之和等于给定目标数的路径,并且从大到小输出路径 

解题思路:使用dfs来遍历树,此过程中记录路径,注意何时push与pop结点并找全所有路径即可。路径升序我使用to_string来将路径转化为string型再排序。有一个case我未曾找到原因不通过。只拿了23分。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;

int n,m,s,sum = 0;

struct node{
    int weight;
    vector<int> child;
};

vector<node> v;
vector<int> temppath;
vector<string> allpath;

int cmp(string a,string b){
	return a > b;
}

void dfs(int node){

	sum += v[node].weight;
	temppath.push_back(v[node].weight);

	if(sum == s){
		if(v[node].child.size() != 0)  return;
		else//当是子结点时
		{
			string s = "";
			s += to_string(temppath[0]);
			for(int j=1;j<temppath.size();j++)
				s = s + " " + to_string(temppath[j]);
			allpath.push_back(s);
		}
	}

	for(int i=0;i<v[node].child.size();i++){
        dfs(v[node].child[i]);
        sum -= temppath[temppath.size()-1];
        temppath.pop_back();
    }
}

int main(){
	scanf("%d%d%d",&n,&m,&s);
	v.resize(n);
	for(int i=0;i<n;i++)
		scanf("%d",&v[i].weight);

	for(int i=0;i<m;i++){
		int a,b,k;
		scanf("%d%d",&a,&k);
		v[a].child.resize(k);
		for(int j=0;j<k;j++){
			scanf("%d",&b);
			v[a].child[j] = b;
		}
	}

	dfs(0);
	sort(allpath.begin(),allpath.end(),cmp);
	for(int i=0;i<allpath.size();i++){
		cout<<allpath[i]<<endl;
	}

	return 0;
}

方法二:对于接收孩子结点的数据时,每次完全接收完就对孩子结点按照权值进行排序(序号变,根据权值变),这样保证深度优先遍历的时候直接输出就能输出从大到小的顺序。

注意:当sum==target的时候,记得判断是否孩子结点是空,要不然如果不空说明没有到底部,就直接return而不是输出路径。。。(这对接下来的孩子结点都是正数才有用,负权无用)。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;

int n,m,s,sum = 0;

struct node{
    int weight;
    vector<int> child;
};

vector<node> v;
vector<int> temppath;
vector<vector<int>> allpath;

int cmp(int a,int b){//注意这里根据结点权重来排序
	return v[a].weight > v[b].weight;
}

void dfs(int node){

	sum += v[node].weight;
	temppath.push_back(v[node].weight);

	if(sum == s){
		if(v[node].child.size() != 0)  return;
		else//不是叶结点,并且值符合要求
		{
			allpath.push_back(temppath);
		}
	}

	for(int i=0;i<v[node].child.size();i++){
        dfs(v[node].child[i]);
        sum -= temppath[temppath.size()-1];
        temppath.pop_back();
    }
}

int main(){
	scanf("%d%d%d",&n,&m,&s);
	v.resize(n);
	for(int i=0;i<n;i++)
		scanf("%d",&v[i].weight);

	for(int i=0;i<m;i++){
		int a,b,k;
		scanf("%d%d",&a,&k);
		v[a].child.resize(k);
		for(int j=0;j<k;j++){
			scanf("%d",&b);
			v[a].child[j] = b;
		}
		sort(v[a].child.begin(),v[a].child.end(),cmp);
	}

	dfs(0);
	for(int i=0;i<allpath.size();i++){
		vector<int> path = allpath[i];
		for(int j=0;j<path.size();j++)
            printf("%d%c",path[j],j==path.size()-1?'\n':' ');
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82688996