#1053. Path of Equal Weight【树的遍历】

原题链接

Problem Description:

Given a non-empty tree with root R R R, and with weight W i W_i Wi assigned to each tree node T i T_i Ti. The weight of a path from R R R to L L L is defined to be the sum of the weights of all the nodes along the path from R R R to any leaf node L L L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
在这里插入图片描述

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N ≤ 100 0<N\leq 100 0<N100, the number of nodes in a tree, M M M ( < N <N <N), the number of non-leaf nodes, and 0 < S < 2 30 0<S<2^{30} 0<S<230, the given weight number. The next line contains N N N positive numbers where W i W_i Wi ( < 1000 <1000 <1000) corresponds to the tree node T i T_i Ti. Then M M M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence { A 1 , A 2 , ⋯   , A n } \lbrace A_1, A_2,\cdots ,A_n \rbrace { A1,A2,,An} is said to be greater than sequence { B 1 , B 2 , ⋯   , B m } \lbrace B_1, B_2,\cdots ,B_m\rbrace { B1,B2,,Bm} if there exists 1 ≤ k < min ⁡ { n , m } 1\leq k<\min \lbrace n,m\rbrace 1k<min{ n,m} such that A i = B i A_i = B_i Ai=Bi​ for i = 1 , ⋯   , k i=1,\cdots ,k i=1,,k, and A k + 1 > B k + 1 A_{k+1} > B_{k+1} Ak+1>Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

Problem Analysis:

题目要求我们在遍历树的过程中,所有自根到叶子的路径的权值和如果等于给定权值 S,就将这个路径保存下来,最终遍历完所有节点后,将所有保存下来的路径从大到小输出。

路径可以用二维 vector 来保存,因为 vector<vector<int>> 可以自动对数组排序。

至于每次搜索的权值和以及路径 path,可以作为参数放到 dfs 中。众多细节见代码及注释。

Code

#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

const int N = 110;

int n, m, S;
vector<vector<int>> ans;
bool g[N][N];
int w[N];

void dfs(int u, int s, vector<int>& path)
{
    
    
    bool is_leaf = true;
    for (int i = 0; i < n; i ++ )
        if (g[u][i])
        {
    
    
            is_leaf = false;
            break;
        }
    if (is_leaf)
    {
    
    
        if (s == S) ans.push_back(path);
    }
    else
    {
    
    
        for (int i = 0; i < n; i ++ )
            if (g[u][i])
            {
    
    
                path.push_back(w[i]);
                dfs(i, s + w[i], path);
                path.pop_back();
            }
    }
}

int main()
{
    
    
    cin >> n >> m >> S;
    for (int i = 0; i < n; i ++ ) cin >> w[i];
    
    while (m -- )
    {
    
    
        int id, k;
        cin >> id >> k;
        while (k -- )
        {
    
    
            int son;
            cin >> son;
            g[id][son] = true;
        }
    }
    vector<int> path({
    
    w[0]});
    dfs(0, w[0], path); // 当前搜到的点,当前的节点权重之和,当前的路径
    sort(ans.begin(), ans.end(), greater<vector<int>>());
    
    for (auto p : ans)
    {
    
    
        cout << p[0];
        for (int i = 1; i < p.size(); i ++ ) cout << ' ' << p[i];
        cout << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121012049