PTA A 1053 Path of Equal Weight

Given a non-empty tree with root R, and with weight W​i assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2
​30 , the given weight number. The next line contains N positive numbers where W
​i
​​ (<1000) corresponds to the tree node T
​i
​​ . Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A
​1
​​ ,A
​2
​​ ,⋯,A
​n
​​ } is said to be greater than sequence {B
​1
​​ ,B
​2
​​ ,⋯,B
​m
​​ } if there exists 1≤k<min{n,m} such that A
​i
​​ =B
​i
​​ for i=1,⋯,k, and A
​k+1
​​ >B
​k+1
​​ .

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

#include<cstdio>
#define maxn 102
#include<algorithm>
#include<vector>
#include<cmath>
#include<iostream>
#include<queue>
using namespace std;
//输入数据生成其对应的树,对树进行先根遍历(DFS),每次将当前访问的结点的权值累加,并将结点加入答案数组
//如果当前权和等于给出的权值,进行"剪枝",即到达递归边界,输出答案序列,如果大于则也到达递归边界
//树的子结点用vector存储,使用静态方法存储树,用下标代替指针,由于题目要求降序输出答案序列,故在子结点vecotr
//中,先排序,这样DFS过程总是先求出权和最大的答案序列
struct node
{
    
    
    int w;
    vector<int>child;
}Node[maxn];
vector<int>ans;
int S;
int sumw=0;
bool cmp(int a,int b)
{
    
    
    return Node[a].w>Node[b].w;

}
void preorder(int root)
{
    
    
    sumw+=Node[root].w;
    ans.push_back(Node[root].w);
    if(sumw==S){
    
    
            if(Node[root].child.size()==0){
    
    //是根节点
        for(int i=0;i<ans.size();i++){
    
    
            if(i!=ans.size()-1){
    
    
                printf("%d ",ans[i]);
            }
            else{
    
    
                printf("%d\n",ans[i]);
            }
        }
        sumw-=Node[root].w;
        ans.pop_back();
        return ;
            }
            else{
    
    
                sumw-=Node[root].w;
                ans.pop_back();
                return ;
            }
    }
    if(sumw>S){
    
    
        sumw-=Node[root].w;
        ans.pop_back();
        return ;
    }
    for(int i=0;i<Node[root].child.size();i++){
    
    
        preorder(Node[root].child[i]);
    }
    sumw-=Node[root].w;
    ans.pop_back();
}
int main()
{
    
    
    int N,M;
    scanf("%d %d %d",&N,&M,&S);
    for(int i=0;i<N;i++){
    
    
        scanf("%d",&Node[i].w);
    }
    while(M--){
    
    
    int index,i;
    scanf("%d %d",&index,&i);
    for(int j=0;j<i;j++){
    
    
        int temp;
        scanf("%d",&temp);
        Node[index].child.push_back(temp);
    }
    sort(Node[index].child.begin(),Node[index].child.end(),cmp);
   }
    preorder(0);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45890608/article/details/111326440