A1053. Path of Equal Weight (30)

1053. Path of Equal Weight (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2

10 3 3 6 2

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;

struct node{
	int weight;
	vector<int> child;
}; 

node T[110];
vector<int> v;
vector<int> ans[110];
int t1=0;

int cmp1(int a,int b)
{
	return T[a].weight>T[b].weight;
}
void dfs(node* T,int root,int s1,int sm){
	
	v.push_back(T[root].weight);
	sm+=T[root].weight;
	if(T[root].child.size()==0)  //叶节点 
	{
		if(sm==s1) 
			ans[t1++]=v;
		v.pop_back();
		//sort(ans[t1].begin(),ans[t1].end());
	}
	
	sort(T[root].child.begin(),T[root].child.end(),cmp1);
	for(int i=0;i<T[root].child.size();i++)
	{
		dfs(T,T[root].child[i],s1,sm);
		if(i==T[root].child.size()-1)
			v.pop_back();
	}
				
}

//zi
int cmp(vector<int>a,vector<int>b)
 {
     int len1,len2;
     len1=a.size();
     len2=b.size();
 
     int i;
     for (i=0;i<len1 && i<len2;i++)
     {
         if (a[i]==b[i])continue;
         else  return (a[i]>b[i]);
     }
     return (len1>len2);
}

int main(){
	//freopen("e:/pat_2017/A1053.txt","r",stdin);
	int n,m,s;
	scanf("%d%d%d",&n,&m,&s);
	
	for(int i=0;i<n;i++)
		scanf("%d",&T[i].weight);
	
	for(int i=0;i<m;i++)
	{
		int t,temp,k;
		scanf("%d%d",&t,&k);
		for(int j=0;j<k;j++)
		{
			scanf("%d",&temp);
		//	printf("%d\n",temp);
			T[t].child.push_back(temp);
		}
	}
	
	dfs(T,0,s,0);
	
	//排序该如何排呢?
	//sort(ans,ans+t1,cmp);
	for(int i=0;i<t1;i++)
	{
		for(int j=0;j<ans[i].size();j++)
		{
			if(j!=0)
				printf(" ");
			printf("%d",ans[i][j]);
		}
		printf("\n");
	}
	
	return 0;
}

注意点,输出结果时,两种处理方式:

1、深度优先搜索时,每次选择权重最大的节点先遍历;

2、对结果进行排序,自己写一个排序方法;cmp

猜你喜欢

转载自blog.csdn.net/dh2442897094/article/details/78209100