PAT Advanced1053 Path of Equal Weight(DFS,树)

版权声明:个人学习笔记记录 https://blog.csdn.net/Ratina/article/details/86575269

链接:PAT Advanced1053

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230​​ , the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti​​ . Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​ ,A​2​​ ,⋯,A​n​​ } is said to be greater than sequence {B​1​​ ,B​2​​ ,⋯,B​m​​ } if there exists 1≤k<min{n,m} such that A​i​​ =B​i​​ for i=1,⋯,k, and A​k+1​​ >B​k+1​​ .

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2



题意:

给定一棵树和每个结点的权值,求所有从根结点到叶子结点的路径,使得每条路径上的结点的权值之和等于给定的常数S(按顺序输出路径上结点的权值)。如果有多条这样的路径,按路径非递增的顺序输出。


分析:

①因为并非二叉树,所以子树不止2棵;因为题目给出每个结点编号,所以采用数组静态构建树更为方便,直接用编号做为下标(地址)。

struct node
{
	int W;             //权值
	vector<int> sub;   //用于存储子树编号
}Node[110];

②关于最后要按路径非递增输出,用vector就可以很方便的处理,因为vector<基本数据类型>是可以直接用关系运算符(>,<,<=,>=,!=,==)进行比较的,那么就可以构造cmp函数了。

vector<vector<int> > ans;
bool cmp(vector<int> a,vector<int> b )
{
	return a>b;
}

以下完整代码:

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
struct node
{
	int W;
	vector<int> sub;
}Node[110];
int M,N,S;
vector<int> temp;
vector<vector<int> > ans;
bool cmp(vector<int> a,vector<int> b )
{
	return a>b;
}
void DFS(int root,int sum)
{
	if(sum>=S)
	{
		if(sum==S&&Node[root].sub.empty())  //后一个判断条件确保结束结点为叶结点
			ans.push_back(temp);            //叶结点无子树,其sub为空
		return;
	}
	for(int i=0;i<Node[root].sub.size();i++)
	{
		int next=Node[root].sub[i];
		temp.push_back(Node[next].W);
		DFS(next,sum+Node[next].W);
		temp.pop_back();
	}
}
int main()
{
	scanf("%d %d %d",&N,&M,&S);
	for(int i=0;i<N;i++)
		scanf("%d",&Node[i].W);
	for(int i=0;i<M;i++)
	{
		int ID,K,t;
		scanf("%d %d",&ID,&K);
		while(K--)
		{
			scanf("%d",&t);
			Node[ID].sub.push_back(t);
		}
	}
	temp.push_back(Node[0].W);        //先把根结点放入
	DFS(0,Node[0].W);
	sort(ans.begin(),ans.end(),cmp);  //排序
	for(int i=0;i<ans.size();i++)     //输出
	{
		for(int j=0;j<ans[i].size();j++)
		{
			if(j!=0)
				printf(" ");
			printf("%d",ans[i][j]);
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ratina/article/details/86575269