1993:Hello World for U

问题 B: Hello World for U

时间限制: 1 Sec  内存限制: 32 MB
提交: 281  解决: 178
[提交][状态][讨论版][命题人:外部导入]

题目描述

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d

e  l

l  r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出

For each test case, print the input string in the shape of U as specified in the description.

 

样例输入

helloworld!

样例输出

h   !
e   d
l   l
lowor
#include<iostream>
#include<string>
using namespace std;

int main() {
	string s;
	cin >> s;
	int n = s.length(), len = (n + 2) / 3, kg = n - len * 2;
	for (int i = 0; i < len - 1; i++) {
		cout << s[i];
		for (int j = 0; j < kg; j++) {
			cout << " ";
		}
		cout << s[n - i - 1] << endl;
	}
	for (int i = len - 1; i < len + kg + 1; i++) {
		cout << s[i];
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36502291/article/details/82143102
今日推荐