poj1961 && hdu1358 Period KMP

Period

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

思路:

预处理nxt数组存前面的最长前后缀,对于整个字符串来说,如果len % (len - nxt[len - 1]) == 0,那么这个字符串肯定是有周期的并且周期T = len / (len - nxt[len - 1]),否则输出1;

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 1010;
char f[maxn],s[maxn];
int nxt[maxn];

void init(int m)
{
	int i = 1,j = 0;
	nxt[0] = 0;
	while (i < m)
	{
		if (s[i] == s[j])
			nxt[i ++] = ++ j;
		else if (!j)
			i ++;
		else
			j = nxt[j - 1];
	}
}
int kmp(int n,int m)
{
	int i = 0,j = 0,res = 0;
	while (i < n)
	{
		
		if (s[j] == f[i])
			i ++,j ++;
		else if (!j)
			i ++;
		else
			j = nxt[j - 1];
		if (j == m)
			j = 0,res ++;
	}
	return res;
}
int main()
{
	while (~scanf("%s",f) && strcmp(f,"#") != 0)
	{
		scanf("%s",s);
		int len = strlen(s),n = strlen(f);
		init(len);
		printf("%d\n",kmp(n,len));
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81814350