Period HDU - 1358(KMP)

版权声明:转载请标明出处 https://blog.csdn.net/weixin_41190227/article/details/86573731

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:对于字符串的每一个前缀,如果存在循环节,就输出所在位置以及循环节的个数。

思路:运用KMP的Next数组,对字符串的每一个位置进行判断,判断是否存在循环节即可。

/*
@Author: Top_Spirit
@Language: C++
*/
//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std ;
typedef unsigned long long ull ;
typedef long long ll ;
const int Maxn = 1e6 + 10 ;
const int INF = 0x3f3f3f3f ;
const double PI = acos(-1.0) ;
const ull seed = 133 ;

string s ;
int n;
int Next[Maxn] ;

void getNext(){
    Next[0] = -1 ;
    int j = 0, k = -1 ;
    while (j < n){
        if (k == -1 || s[j] == s[k]) Next[++j] = ++k ;
        else k = Next[k] ;
    }
}

int main (){
    ios_base::sync_with_stdio(false) ;
    cin.tie(0) ;
    cout.tie(0) ;
    int Cas = 0;
    while (cin >> n && n){
        cin >> s ;
        getNext();
        printf("Test case #%d\n",++Cas);
        for (int i = 0; i <= n; i++){
            if (Next[i] == 0 || Next[i] == -1){
                continue ;
            }
            int k = i - Next[i];
            if (i % k == 0){
                printf("%d %d\n",i,i / k);
            }
        }
        puts("");
    }
    return 0 ;
}

猜你喜欢

转载自blog.csdn.net/weixin_41190227/article/details/86573731