HDU 1358 Period (kmp数组)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1358点击打开链接

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10191    Accepted Submission(s): 4861


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
 
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
 
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

应该很容易联想到kmp里next数组的表示与此题相关 

根据len-next【len】计算循环节长度判断是否为多个循环节即可输出

#include <bits/stdc++.h>
using namespace std;
string s,t;
int n,m;
int nnext[1111111];
void getnext()
{
	int i=0,j=-1;
	nnext[0]=-1;
	while(i<n)
	{
		if(j==-1||t[i]==t[j])
		{
			i++;
			j++;
			nnext[i]=j;
			int mid=i-nnext[i];
			//cout << mid <<" " << i << endl;
			if(mid!=i&&i%mid==0&&(i/mid)>=2)
				printf("%d %d\n",i,i/mid);
		}
		else
		{
			j=nnext[j];
		}
	}
}
int  main()
{
	int ccnt=0;
	while(scanf("%d",&n)&&n!=0)
	{
		printf("Test case #%d\n",++ccnt);
		cin >> t;
		n=t.length();
		getnext();
		printf("\n");
	}
}






猜你喜欢

转载自blog.csdn.net/xuejye/article/details/79251769