HDU 1358 Period(KMP中next数组的运用)

题目链接

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

PS:题意:求字符串的前缀是否为周期串,若是,打印循环节长度和循环次数。

已经在KMP算法中,next数组保存的是当前字符串中能够匹配的最长前后缀的长度。

我们以 aabaabaabaab 为例。

当next数组满足i%(i-next[i])==0。且next[i]!=0。说明当前字符串中前缀为周期串,且循环次数为i/(i-next[i]);

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
const int maxn=1e6+10;
const int mod=10007;
const int inf=1e8;
#define me(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&(-x)
typedef long long ll;
using namespace std;
char str[maxn];
int nex[maxn];
int main()
{
    int n,Case=1;
    while(scanf("%d",&n)&&n)
    {
        scanf("%s",str);
        nex[0]=nex[1]=0;
        for(int i=1;i<n;i++)
        {
            int k=nex[i];
            while(k&&str[i]!=str[k])
                k=nex[k];
            nex[i+1]=str[i]==str[k]?++k:0;
        }
        printf("Test case #%d\n",Case++);
        for(int i=1;i<=n;i++)
            if(nex[i]&&i%(i-nex[i])==0)
                printf("%d %d\n",i,i/(i-nex[i]));
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/86553469