HDU 1358 KMP循环节

http://acm.hdu.edu.cn/showproblem.php?pid=1358

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题目大意: 给一个字符串序列s, 对于s的每一个前缀S(长度至少要大于等于2), 若有字符串循环节满足AA……A(一共k个且k>1)=S, 则输出前缀S的长度以及k的值。

思路: 下面那个博客有对KMP算法的简要介绍,博客最后也有对循环节的简单介绍。

https://blog.csdn.net/xiji333/article/details/88614354

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<map>
#include<algorithm>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

int Next[1000005];
char a[1000005];
int n;

void getnext()
{
    Next[0]=-1;
    int j=0,k=-1;
    while(j<n)
    {
        if(k==-1||a[j]==a[k])
        {
            ++j,++k;
            Next[j]=k;
        }
        else
            k=Next[k];
    }
}

int main()
{
    int times=0;
    while(~scanf("%d",&n)&&n)
    {
        scanf("%s",a);
        getnext();
        printf("Test case #%d\n",++times);
        for(int i=0;i<=n;i++)
        {
            if(Next[i]==-1||Next[i]==0)
                continue;
            int len=i-Next[i];
            if(i%len==0)
                printf("%d %d\n",i,i/len);
        }
        putchar('\n');
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiji333/article/details/88727275