HDU-1358-Period(kmp)

                                                           Period
 

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意描述:

给你一个字符串找其中有多少个子串可以构成循环串,并把循环串的长度和循环节的个数输出

程序代码:

#include<stdio.h>
#include<string.h>
void get_next(char *s);
int next[1000010],n;
char a[1000010];
int main()
{
	int i,t,k=0;
	while(scanf("%d",&n)!=EOF)
	{
		k++;
		if(n==0)
			break;
		scanf("%s",a);
        get_next(a);
        printf("Test case #%d\n",k);
        for(i=1;i<=n;i++)
        {
        	t=i-next[i-1];
        	if(t!=i&&i%t==0)
        		printf("%d %d\n",i,i/t);
		}
		printf("\n");
	}
	return 0;
}
void get_next(char *s)
{
	int i,j;
	i=1;j=0;next[0]=0;
	while(i<n)
	{
		if(j==0&&s[i]!=s[j])
		{
			next[i]=0;
			i++;
		}
		else if(j>0&&s[i]!=s[j])
			j=next[j-1];
		else
		{
			next[i]=j+1;
			i++;
			j++;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81165996