hdu1358:Period

http://acm.hdu.edu.cn/showproblem.php?pid=1358

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3

aaa

12

aabaabaabaab

0

Sample Output

Test case #1

2 2

3 3

Test case #2

2 2

6 2

9 3

12 4

找出字符串的每一个前缀在字符串中循环出现的位置和第几次出现,不包括第一次出现。

第一个样例aaa,第一个前缀a第二次出现在2,输出2 2,第三次出现在3,输出3 3。第二个前缀aa后面没有出现,第三个前缀aaa后面也没有出现,在每个样例的后面输出一个空行。

#include<stdio.h>
#include<string.h>
#define N 1000020
char a[N];
int n,next[N],sum=1;
void getnext()
{
	int i,j;
	i=0;
	j=-1;
	next[0]=-1;
	while(i<n)
	{
		if(j==-1||a[i]==a[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else
			j=next[j];
	}
}
void kmp()
{
	getnext();
	int i,t;
	printf("Test case #%d\n",sum);
	sum++;
	for(i=1;i<=n;i++)
	{
		t=i-next[i];
		if(i%t==0&&i/t>1)
		    printf("%d %d\n",i,i/t);
	}
}
int main()
{
	while(scanf("%d",&n),n!=0)
	{
		scanf("%s",a);
		kmp();
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41505957/article/details/81713133