PAT 1010 Radix (25 分)

1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1and N2​ , your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.
Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible




解析

这题我感觉又有些神,又有些阴险。



首先进制转换要熟.我这篇Blog给出了进制转换算法笔记。感兴趣的同学可以去看看。
这题我把我的思路复盘下。
首先:得到两个数字 num1,num2。如果 t a g = = 2 tag==2 ,完全可以把两个数字交换。
我想:如果 n u m 1 > n u m 2 num1>num2 ,那就要大的进制。num1==num2 那么进制就是radix
。num1<num2 小的进制。
那么怎么进行比较呢? 因为又0-9,a-z。所以不能直接比较。
那么就规范化。都转化成10进制。
剩下的工作就是通过迭代num2的进制。看在10进制下,num1是否等于num2。



这题很坑:这样把思路写出来,还是不能AC。看了别人的blog:发现:
①数字可能出现0-9,a-z。我还以为最大是36进制。晕
②这题要用二分法。low取数字中出现的(‘0’-‘9’,‘a’-‘z’)最高位.因为是字符。所以很好找到。
high就是 max(num1,low)。为什么要用二分法:因为num1可能很大。
③进制转换难免会溢出。所以要用long long。但是long long 还是有可能溢出的,当溢出的时候是什么情况呢?是根据整num2在这个进制下太大了。要把进制调小一点。根据int类型的知识:溢出后将会是负数。所以num2在这个进制下是负数,就要把进制调小一点。




Code:

#include<iostream>
#include<cstdio>
#include<cctype>
#include<vector>
#include<string>
#include<algorithm>
#include<map>
using namespace std;
const string out = "Impossible";
map<char, int> mapp;
long long radix2dec(const string& temp,int radix) 
{
	long long sum=0,product=1;
	for(int i=temp.size()-1;i>=0;i--){
		sum = sum + mapp[temp[i]]*product;
		product *= radix;
	}
	return sum;
}

int main()
{
	for (int i = 0; i < 10; i++)
		mapp[i + '0'] = i;
	for (char i = 'a'; i <= 'z'; i++)
		mapp[i] = i - 'a'+10;
	string str_num1, str_num2;
	int tag, radix;
	cin >> str_num1 >> str_num2 >> tag >> radix;
	if (tag == 2)
		swap(str_num1, str_num2);
	if (str_num1 == str_num2)
		cout << radix;
	else {
		long long num1 = radix2dec(str_num1, radix), num2;
		auto it = max_element(str_num2.begin(), str_num2.end());
		long long low = (isdigit(*it)?*it-'0':*it-'a'+10)+1, high = max(num1,low);
		while (low <= high) {
			int mid = (low + high) / 2;
			num2 = radix2dec(str_num2, mid);
			if (num1 == num2) {
				cout << mid;
				return 0;
			}
			else if(num2>num1 || num2<0)
				high = mid - 1;
			else
				low = mid + 1;
		}
		cout << out;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/82822370