PAT Advanced 1010 Radix (25分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1​​ and N2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

 

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10
 

Sample Output 1:

2
 

Sample Input 2:

1 ab 1 2
 

Sample Output 2:

Impossible

我本来打算用枚举,这种方法有1个case失误:

#include <iostream>
#include <algorithm>
using namespace std;
/** 一个N 通过radix转换为10进制 */
int itod(string N, int radix) {
    int p = 1, res = 0;
    for(int i = N.length() - 1; i >= 0; i--){
        if(isdigit(N[i])) res += ((N[i] - '0') * p);
        else res += ((N[i] - 'a' + 10) * p);
        p *= radix;
    }
    return res;
}
int main(){
    string N1, N2;
    int tag, radix;
    cin >> N1 >> N2 >> tag >> radix;
    if(tag == 2) swap(N1, N2); // 交换后 radix一定表示N1
    int N1d = itod(N1, radix);
    char max_char = 0;// 求出最大的字符
    for(int i = 0; i < N2.length(); i++)
        if(N2[i] > max_char) max_char = N2[i];
    int r;// 最小的进制
    if(isdigit(max_char)) r = max_char - '0' + 1;
    else r = max_char - 'a' + 11;
    /** 从最小进制向35进行遍历,如果转换结果相等,则输出 */
    for(; r <= 50; r++){
        if(itod(N2, r) == N1d) {
            cout << r;
            system("pause");
            return 0;
        }
    }
    cout << "Impossible";
    system("pause");
    return 0;
}

柳神做法,二分法:

#include <iostream>
#include <cctype>
#include <algorithm>
#include <cmath>
using namespace std;
long long convert(string n, long long radix) {
    long long sum = 0;
    int index = 0, temp = 0;
    for (auto it = n.rbegin(); it != n.rend(); it++) {
        temp = isdigit(*it) ? *it - '0' : *it - 'a' + 10;
        sum += temp * pow(radix, index++);
    }
    return sum;
}
long long find_radix(string n, long long num) {
    char it = *max_element(n.begin(), n.end());
    long long low = (isdigit(it) ? it - '0': it - 'a' + 10) + 1;
    long long high = max(num, low);
    while (low <= high) {
        long long mid = (low + high) / 2;
        long long t = convert(n, mid);
        if (t < 0 || t > num) high = mid - 1;
        else if (t == num) return mid;
        else low = mid + 1;
    }
    return -1;
}
int main() {
    string n1, n2;
    long long tag = 0, radix = 0, result_radix;
    cin >> n1 >> n2 >> tag >> radix;
    result_radix = tag == 1 ? find_radix(n2, convert(n1, radix)) : find_radix(n1, convert(n2, radix));
    if (result_radix != -1) {
        printf("%lld", result_radix);
    } else {
        printf("Impossible");
    }   
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/littlepage/p/12240223.html