PAT甲级真题(二分)——1010 Radix (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/85764785

1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is “yes”, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:N1 N2 tag radix Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number “radix” is the radix of N1 if “tag” is 1, or of N2 if “tag” is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print “Impossible”. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

题目大意:

给定两串数字,已知其中一个的基数,求另一串数使两数相等的基数,如果不存在这样的基数,输出Impossible。

题目解析:

用long long型变量存储转换后的数N,然后用二分法求另一个的基数。
要注意的是:

  • low取这串数字的最大数加一,high取max(low,N);
  • 由于在计算进制转换后的数字temp时可能会发生溢出,所以当temp<0时应缩小上界;

具体代码:

#include<iostream>
#include<algorithm>
#include<cctype>
using namespace std;

long long convert(string s,long long radix){
	long long sum=0;
	int temp;
	for(int i=0;i<s.size();i++){
		temp=isdigit(s[i])?s[i]-'0':s[i]-'a'+10;
		sum=sum*radix+temp;
	}
	return sum;
}

int main() {
	string n[3];
	long long tag,radix,num=0;
	cin>>n[1]>>n[2]>>tag>>radix;
	num=convert(n[tag],radix);
	tag=(tag==1)?2:1;
	//利用二分法找出满足的基数
	char it=*max_element(n[tag].begin(), n[tag].end());
	long long low=(isdigit(it)?it-'0':it-'a'+10)+1;
	long long high=num>low?num:low,mid;
	while(low<=high){
		mid=low+(high-low)/2;
		long long temp=convert(n[tag],mid);
		if(temp==num){
			cout<<mid;
			return 0;
		}else if(temp<0||temp>num)//如果大于num,则说明基数太大了;如果溢出了temp就小于0 
			high=mid-1;
		else
			low=mid+1; 
	}
	cout<<"Impossible";
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29978597/article/details/85764785