PAT-A 1152 Google Recruitment

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/JoJoSIR/article/details/84963174

      In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

      The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

       Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5

23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

题意:

       给出一串数字,指定位数k,求第一个出现的连续k位数字构成的素数,由于k小于10,不会超出int的范围,所以只需要使用int存储k位数,并判断是否为素数。需要注意的是,题目中说明了,首位数字不可在前面补零,但其余数字位上的零不可忽略,并要求原样输出,比如200236,k=4,则第一个4位素数是0023,不能输出23。

Code:

#include <stdio.h>
#include <math.h>
using namespace std;

int n, k;

bool isPrime(int test){
    if(test == 0 || test == 1) return false;
    for(int i = 2; i * i <= test; i++){
        if(test % i == 0) return false;
    }
    return true;
}

int main(){
    scanf("%d %d", &n, &k);
    char num[1005];
    getchar();
    for(int i = 0; i < n; i++)
        scanf("%c", &num[i]);

    bool flag = false;
    for(int i = 0; i <= n - k; i++){
        int t = 0, c = 10;
        for(int j = i; j < i + k; j++)
            t = (t * c + (num[j] - '0'));
        flag = isPrime(t);
        if(flag){
            for(int j = i; j < i+ k; j++)
                printf("%c", num[j]);
            printf("\n");
            break;
        }
    }
    if(!flag) printf("404\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/JoJoSIR/article/details/84963174