PAT Advanced 1152 Google Recruitment (20 )

问题描述:

1152 Google Recruitment (20 分)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

半年没写代码的博主感觉自己宛如一个制杖,直接2-√n的素数判断就可以AC了,根本不需要筛素数,第五个测试点是关于l=k的情况的。。。

AC代码:

#include<bits/stdc++.h>
using namespace std;
inline bool prim(int n)
{
	if(n)
	{
		if(n==1||n==2)
		return true;
		else
		{
			for(int i=2;i<sqrt(n);i++)
			if(!(n%i)) return false;
			return true;
		}
	}
	else
	return false;
}
int main()
{
 // 	freopen("data.txt","r",stdin);
	int l,k,s0;
	bool flag=true;
	char s[1000],st[10];
	scanf("%d %d %s",&l,&k,s);
	if(k<=l)
	{
		for(int i=0;i+k<=strlen(s);i++)
		{
			strncpy(st,s+i,k);
			st[k]='\0';
			sscanf(st,"%d",&s0);
			if(prim(s0))
			{
				flag=false;
				printf("%s",st);
				break;
			}
		}
	}
	if(flag)
	printf("404");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/baidu_37550206/article/details/85269487