1152 Google Recruitment (20 分)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

PS题外话:CSDN编辑器是真的laji

解题思路:主要就是把字符串转换为整数,然后判断素数(普通判断方法就行),开始想的是筛法判断素数,但是数组开不了1e9,普通方法也能过;

会两个函数能使问题更简单:一个是string转换为int函数:atoi(s.c_str());一个是提取string子串函数:s.substr(i,k) /*i为子串起始位置,k为子串长度)*/

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

bool judge(int t)
{
    if(t==0) return false;
    if(t==1) return false;
    for(int i = 2; i <= sqrt(t); i++){
        if(t%i==0) return false;
    }
    return true;
}

int change(string s)
{
    return atoi(s.c_str());
}

int main()
{
    string l;
    int n,k;
    bool FIND = false;
    cin >>n>>k>>l;
    for(int i = 0; i < n-k+1; i++){
        string str = l.substr(i,k);
        int t = change(str);
        if(judge(t)){
            cout << str;
            FIND = true;
            break;
        }
    }
    if(!FIND){
        cout << "404";
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_36313227/article/details/88996750